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What is Rosetta-J?

Rosetta-] is a software tool that you can use to translate the Tracker client's
interface text, such as menu item text and error messages. Rosetta-] works with
the Tracker client computer’s properties files to display the Tracker terms, and
then displays another column where you can type the translation of the term in
another language. Rosetta-] is not installed as part of the Tracker client
installation; it requires a separate installation.

NOTE: You must install Rosetta-] on the client computer where the translation will be
performed; the Tracker client must also be installed on this computer. Once you have the
appropriate properties files translated, you can then copy these files to the other Tracker
client computers, thereby eliminating the need to install Rosetta-] on each Tracker client
computer,

How Rosetta-J Works: The Basics
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Figure 1. Basic Rosetta-J Workflow

The Tracker client uses a series of five properties files (TTerms.properties,
TMessages.properties, ISOCodeRes.properties, basic.properties, and
UlStrings.properties) and their translated variants (such as
TTerms_de.properties) to display its interface text and message windows.
Rosetta-] is a tool you can use to display the contents of the properties file and
then type the translation of the text entry, or “string,” into the Target Value
column. Definitions of these properties files, including the type of interface text
affected, are listed in “Rosetta-] Definitions” on page 3.

After you have translated all of the base terms by typing their equivalent in the
Target Value column, you save the target terms as a new target file with a specific
name format that contains the International Standards Organization (ISO) two-
character language code. For example, TTerms_es.properties would be the
filename for the TTerms.properties file that contains translated terms in Spanish
(“es” is the two-letter language code for Spanish; see the Appendix of this
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document for a list of the valid International Standards Organization [ISO]
language codes).

How Does the Tracker Client Know Which Language To Display?

The Tracker client uses the properties files that are associated with the locale or
regional setting set for the client computer at the operating system level. For
example, on a client computer running Windows 2000 with its locale set to France
(the French language code is fr), the Tracker client will use the
TTerms_fr.properties, TMessages_fr.properties, UIStrings_fr.properties,
basic_fr.properties, and ISOCodeRes_fr.properties if they exist. If these files have
not yet been created, the Tracker client will use the default files
(TTerms.properties, TMessages.properties, UIStrings, properties, basic.properties,
and ISOCodeRes.properties) that feature an English language translation. For
basic instructions about setting locales on Windows 2000 and Windows XP
computers, see “Setting the Operating System Locale” on page 31. For basic

About the Locations of the Properties Files

The exact location of the Tracker properties files depends on where the Tracker
client is installed on a client. For example, here are the locations for a Windows
2000 or Windows XP client:

If the Tracker client was installed at the default installation location, then the
location for the TTerms.properties and TMessages.properties files is as follows:

Program Files\Tracker\conf\com\fgm\tracker

If the Tracker client was installed at the default installation location, then the
location for the ISOCodeRes.properties and UlStrings.properties files is as follows:

Program Files\Tracker\conf\com\£fgm\util

If the Tracker client was installed at the default location, then the location for the
basic.properties file is:

Program Files\Tracker\conf\javax\swing\plaf\basic\resources

You should locate where the Tracker\conf\com\ fgm\tracker,
Tracker\conf\com\£fgm\util, and
Tracker\conf\javax\swing\plaf\basic\resources folders are on the computer
before beginning translation.

instructions about setting locales on Macintosh OS X computers, see “Setting the
Operating System Locale” on page 54.

Rosetta-J Definitions

The following words and definitions represent important Rosetta concepts.
Understanding these concepts will help you easily work in Rosetta.
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Base File —the starting or “from” file; a file that lists the Tracker interface text
(base terms) that need to be translated. The Tracker client uses five different base
files that you should consider translating and then creating a new target file for
each:

TTerms.properties
UlStrings.properties
TMessages.properties
ISOCodeRes.properties
basic.properties

L L] L] L] L]

If you installed Tracker at the default installation location, these files can be found
on the Tracker client in three different locations: Tracker\ conf\ com\ fgm\ tracker
for the TTerms.properties, TMessages.properties, and UlStrings.properties;
Tracker\ conf\ com\ fgm\ util for ISOCodeRes.properties; and

Tracker\ conf\ javax\swing\ plaf\ basic\ resources for basic.properties. You
should not create, modify, or delete a base file in Rosetta because doing so could
cause Rosetta to function improperly.

basic.properties —one of the five properties files used by the Tracker client; this
file affects text in components supplied by the Java runtime system, such as the
File Chooser window that is accessible from the Documents window in the
Tracker client.

Base Terms —the Tracker interface text that need to be translated; this text is
listed in the second column (Base Value) of the base file. You cannot create,
modify, or delete base terms in Rosetta-].

ISOCodeRes.properties —one of the five properties files used by the Tracker
client; this file affects the text related to country names, languages, currencies, and
units of measure displayed in the Tracker client.

Target File —the translated or “to” file; a file where you type the translated
equivalents of the base terms. You'll either create a new target file if you have not
created one previously, or open an existing target file if you have created one and
need to update it. Each translated target file name must be properly formed with
the name, an underscore, the two-character language code, and the file extension
(for example, TTerms_ru.properties). For language variants, the file name can
include up to two additional language codes (for example,
TTerms_en_uk.properties).

Target Terms —the translated equivalents of the base terms; once created, the
target terms are the text that displays in the Tracker client when the client
computer’s operating system is set to the corresponding locale. The target terms
are part of the target file and can be modified as needed.
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TMessages.properties —one of the five properties files used by the Tracker client;
this file affects the text related to the Tracker client’s error messages.

TTerms.properties —one of the five properties files used by the Tracker client;
this file affects the text related to non-error messages and export control domain
terms displayed in the Tracker client.

UlStrings.properties —one of the five properties files used by the Tracker client;
this file affects the text related to menus, menu items, buttons, and labels
displayed in the Tracker client.

Rosetta-J Interface

Rosetta-]'s interface opens without displaying a base or target file. You must open
a base file or a base and a target file to populate the window with keys and base
values. The Target Value column populates when you open a target file that has
been translated.

The Key column lists the code references; you do not need to use the text in the
Key column. The Base Value column lists the text exactly as it appears in the
default English-language version of Tracker (if you opened a properties file that
does not feature an underscore and a two-character language code). You will
need to translate the base value text into the Tracker client users’ language(s). The
target value column is where you will type the translation for the base term that
appears to the left of the target value column.
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Figure 2. Rosetta-J opens without displaying base or target files.

Once you've selected an existing base and target file or opened a base file only,
the interface displays the key terms, base values, and target values (if they exist)

in the appropriate columns.

Menu Options

Rosetta-] features a menu bar at the top of the window. This menu bar offers
access to all of Rosetta-J’s functionality. The following table lists the Rosetta-]

menu options,

Table 1: Rosetta-J Menu Options

Select This Menu Option

To Do This

File>Open Base File Open an existing base file to determine which
terms need to be translated.

File>New Target File Create a new target file with a column for
typing the translated target terms.

File>Open Target File Open an existing target file so you can make
changes to the translated target terms.
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Table 1: Rosetta-J Menu Options

Select This Menu Option

To Do This

File>Save

For new files, saves the open target file with a
name of your choice. All file names must
follow the naming convention of
Name_xx.properties (such as
TTerms_es.properties), where you replace
Name with the name (TTerms, TMessages,
UlStrings, basic, or ISOCodeRes) and the xx
with the proper two character ISO language
code for your country (for example,
TMessages_es.properties). The Appendix
lists the official two-character language
codes. If the file has already been named,
then selecting File>Save saves without
prompting for a file name,

File>Save As

Save the open target file with a different
name. You must name files with an
appropriate name that is recognizable by the
Tracker clients and servers. This naming
convention involves the format
Name_xx.properties, where Name is
replaced with the name (TTerms, TMessages,
UlStrings, basic, or ISOCodeRes) and xx is
replaced with the two character ISO language
code for your country. For example, the file
translated in Russian would be named
TTerms_ru.properties. The Appendix lists
the official two-character language codes.

File>Revert

Discard any changes since the last save or the
last open action, whichever was more recent.

File>Exit

Close the Rosetta-] application. Using this
menu option to exit the application is
recommended because you will be prompted
to save your changes, provided you click out
of the cell you just changed. Clicking the
Close icon will not prompt you to save your
changes before closing, though it will ask you
to confirm the exit.

Edit>Find

Search the open base or target file for the text
you type in the find dialog box.

Edit>Find Next

Find the next occurrence of the text you
typed in the find dialog box.

<
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Table 1: Rosetta-J Menu Options

Select This Menu Option

To Do This

Edit>Replace

Replace the text you are searching for with
the substitute text you type in the Find/
Replace dialog box. This option is operational
in target files only.

Edit>Preferences

Open the Preferences window so you can
make changes to your Rosetta-] preferences,
such as highlight colors.

Help>About Rosetta-]

Open the Rosetta-] About window, which
displays information about Rosetta-J (such as
the version number).
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Who Should Use Rosetta-J?

Rosetta-] is intended for anyone who translates terms, including:

Translators

Linguists

Language specialists

Export officials with translation experience

Because it is easy to use, you do not need extensive computer experience to
employ Rosetta-]. Tracker includes sample (but unverified for content or domain
accuracy) language translations for each of the properties files. The properties
files with a “ru” in their filename feature a sample Russian translation, the “fr”
feature a sample French translation, the “de” feature a sample German
translation, and those without the two-character language code feature a valid
English translation. It is recommended that you use the sample translations in a
consulting manner only because the accuracy of these translations cannot be
guaranteed. You should open the English language properties file (it lacks a
language code, such as TTerms.properties) when beginning your translation so
you can use the file as your base file from which you create the target file.
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How to Use this Guide

The Rosetta-] User’s Guide is divided into two categories of information:
introduction and instruction. The introduction is what you are reading now. This
category includes definitions and general Rosetta-] information. The instruction
category, Using Rosetta-], contains the step-by-step procedures for translating the
Tracker client terms on a Mac OS X, Windows 2000, or Windows XP-based client
computer,

Guide Conventions

This guide uses task-oriented, numbered procedures. The procedures include
system responses that tell you what happens after you complete a step in the
procedures.

This guide also uses conventions as outlined in the following table.

Convention Meaning

Click Refers to clicking the primary mouse button once.

Double-click Refers to quickly clicking the primary mouse button
twice.

Bold In procedures, indicates the name of a button or a
menu item, such as the Cancel button or the File
menu.,

Initial In procedures, indicates an icon name, such as the

Capitalization Add icon.

KEY NAME In procedures, indicates a keyboard key name, such
as the ENTER key.

Represents a note. A note appears to the right of this

é symbol.

Represents a warning. When you see this symbol,
A you should carefully read the accompanying text to
understand the warning’s context.

10
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Convention Meaning
Represents a procedure. Procedures appear to the
’ right of this symbol. ;
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Contact Information

Contact information for Rosetta-], along with other useful information, is
conveniently located online at TrackerNet (www.trackernet.org), the official
support web site of Rosetta-] and Tracker.

TrackerNet

You can access TrackerNet by pointing any web browser to http://

www trackernet.org/. To access TrackerNet's protected content, you'll need a
user ID and password to log into the site. You can obtain a user ID and password
by sending an e-mail request to info@trackernet.org,

12




Using Rosetta-J
(Windows)

O

This section describes how to use the Rosetta-] application for translating the Tracker
client interface. These instructions are designed for Windows 2000 or Windows XP-based
Tracker clients only.

Contents:

L ] o L] e L] L] L] o L ] e L]

Installing Rosetta-]

Opening Rosetta-]

Setting Rosetta-] Preferences
Creating a New Translation
Updating an Existing Translation
Finding Terms in a Base or Target File
Replacing Terms in a Target File
Setting the Operating System Locale
Troubleshooting Tips

Exiting Rosetta-]

Uninstalling Rosetta-]

13
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Installing Rosetta-J

Rosetta-] is not installed as part of the Tracker client installation; therefore, you
must install it separately on a client computer running Windows 2000 or
Windows XP that already has the Tracker client installed. You can choose to
install Rosetta-] on all Tracker client computers running Windows 2000 or
Windows XP, or you can install it on a single Windows-based Tracker client and
then copy the translated properties files to the other Tracker client computers
(recommended approach).

Prerequisites for installation: Windows 2000 or Windows XP; Tracker client.

P To install Rosetta-] on a Windows 2000 or Windows XP-based Tracker client

computer:

1. Insert the Rosetta-] Installation CD-ROM into the client computer’s CD-ROM
drive.

2. Navigate to the CD-ROM’s directory.

3. Double-click the windows folder.

4. Double-click the Rosetta-]J-Install.exe file to begin the installation.

Install Anywhere prepares the installation files,

5. In the Rosetta-J 1.4.1 window, select the language in which you want the
installer to display from the drop-down list of languages. Click the OK
button.

6. In the Introduction window, click the Next button.

7. In the Choose Install Folder window, click the Install button.

select a different installation location; however, the location of your Rosetta-J

? NOTE: This action installs Rosetta-J at the default installation location. You can

application files might be different from the locations described in this document.

8.

When the installation completes, click the Done button.

Rosetta-] is now ready to use, and creates an executable icon on the desktop that
you can double-click to run the Rosetta-] application,

14
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Opening Rosetta-J

Once properly installed, Rosetta-] is easily accessible through the desktop
Rosetta-] icon that is created as part of the installation.

p To open Rosetta-]:

* Double-click the Rosetta-] icon on the Tracker client computer’s desktop.

T o)
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| | | and there are

i || translated target
: | terms

Figure 3. Rosetta-J opens without displaying base or target files,
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Setting Rosetta-J Preferences

Rosetta-] features preferences that you can set to customize the look of your
Rosetta-] application. You can set the following Rosetta-] preferences:

* font
* text highlight colors

All preferences are persistent; therefore, they are retained the next time you use
Rosetta-].

The font preference options affect the way key, base, and target terms appear in
Rosetta-]; this font selection does not affect the appearance of text in the Tracker
interface, The text highlight colors also affect the way key, base, and target terms
appear in Rosetta-J; these colors do not affect the appearance of text in the Tracker
interface, If you want your selected warning colors to appear in Rosetta-], you
must select the Enble color row highlighting option check box.

p To open the User Preferences window:

1. Open the Rosetta application (See “Opening Rosetta-]” on page 15.)
2. TFrom the Edit menu, select Preferences.
The User Preferences window opens.

| Display Font
i

‘ Sample Text: AaBhCc 12346

‘[ Typeface: l:ﬂdﬂﬁ N SR
i Size: 11'4"
L i

| Backarotind Color
.

| [ Enabla color row highlighting
| |
| Dupicate Key: RaBbCe 12345 ...
| OntyinBase file: AABBCE 12545 m |
; Onty in Target File: AaBhCc 12315 it :
{ o)
Figure 4. The
Preferences [ potaur | [ ox || cencer |
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P To set the font used in the Rosetta-] application:
1. Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
2, From the Edit menu, select Preferences.
The User Preferences window opens.
3. From the User Preferences window, in the Display Font section, select the font
name from the Typeface drop-down menu.
A sample of the selected font appears above the drop-down menu, in the
Sample Text field.
Select the font size from the Size drop-down menu,

The font size and name you select affect the text appearing in Rosetta-]'s
base and target files.

=

5. To save the font settings and close the User Preferences window, click the OK
button.

P To set the text highlight colors used in the Rosetta-J application:

1. Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
2. From the Edit menu, select Preferences,
The User Preferences window opens.

3. From the User Preferences window, in the Background Color section, click the
square color palette next to the item whose color you want to change.

The colors open in a separate window. You can set the “duplicate key,”
“only in base file,” and “only in target file” warning colors.

* Duplicate key warning is the color applied to a key term that
appears more than once in a base file,

* Only in base file warning is the color applied to text in a base file
when the text does not appear in the target file. This type of
warning usually indicates the base file has new terms that are not
in the target file; these new terms need to be translated. To sort the
terms so those without translations appear at the top of the
window, click the Target Value column heading.

* Only in target file warning is the color applied to text in a target
file when the text does not appear in the base file. This type of
warning usually indicates the target files has terms that are not in
the base file. This warning normally results from one of three
conditions: an incorrect base file, a term that is no longer in use, or
a term that is moved to a different key.

4, From either the Swatches, HSB, or RGB tab, select the color that you want to
represent the warning type. Click the OK button to save the selection.
The selected color appears in the User Preferences window for the
warning type you selected.

5. Repeat steps 3 and 4 for each color you want to change.

17
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6. To enable warning color display in Rosetta-], make sure the Enable color row

highlighting box is checked.
7. To save the settings and close the User Preferences window, click the OK
button.

P To close the User Preferences window:

1. If you want to close the User Preferences window and save the settings, click
the OK button. '

2. If you want to close the User Preferences window without saving the settings,
click the Cancel button.

p To restore the default settings:

* From the User Preferences window, click the Default button.
This action restores the default Rosetta-] settings.



ﬂ

)

Using Rosetta-J (Windows): Creating a New Translation

Creating a New Translation

Important Note!

é Please read this introductory text carefully before beginning the

translation.

This section is intended for users who want to create a new translation, rather
than update an existing one. If you are working with a new Tracker installation
and do not yet have translations, you will need to translate the following five
properties files (listed directly below as well as after each note):

TTerms.properties
TMessages.properties
UlStrings.properties
ISOCodeRes.properties
basic.properties

Translating terms involves two main activities: opening one of the five properties
files listed above, and populating the target column (which, upon saving, creates
the target file). The base file lists Tracker interface text related to the properties
file. You can then populate the target file by translating the base terms by typing
the translations in the target term column.

The five base files are provided in English, which is a verified translation and
should be used as the base file, and other sample languages. Please be aware that
the sample non-English translations have not been verified for content or domain
accuracy. It is recommended that you only use the non-English translations in a
consulting manner because the accuracy of these translations cannot be
guaranteed. You should open the English properties file (it lacks a language code, -
such as TMessages.properties) when beginning your translation so you can use
the file as your base file from which you create the target file.

After you have translated the base terms and saved the file as a target terms
properties file with a properly constructed file name, you must then set the client
computer’s locale to match the newly created translation’s language code (see
“Setting the Operating System Locale” on page 31 for details). The Tracker client
interacts with the computer’s operating system to determine which properties file
version to use. Because the translations are handled on the client side, each
Tracker client could operate in a different language, provided it is accommodated

19
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by the operating system and accompanied by a properties file with a matching

language code,

WARNING

A\

You must save your target file to the correct location (such as
Program Files\Tracker\conf\com\fgm\tracker for
TTerms.properties and TMessages.properties; Program
Files\Tracker\conf\com\fgm\util for UIStrings.properties,
and ISOCodeRes.properties; or Program
Files\Tracker\conf\javax\swing\plaf\basic\resources for the
basic.properties for Tracker client installations installed at the
default installation location) with a valid file name. A valid file
name contains the structure Name_xx.properties, where the
Name is replaced with one of five applicable file names (TTerms,
TMessages, basic, UlStrings, or ISOCodeRes) and xx is replaced
with the appropriate two-character ISO country code for the file's
language. For example, TTerms_fr.properties is a correct file
name. See the Appendix for a list of valid language codes.

Translations occur on the Tracker client machine only, not the
server. Each client computer requires the appropriate translated
properties files, which can be created by copying the files from a
completed translation on a single client; therefore, Rosetta-] does
not need to be installed on all Tracker client computers.
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P To translate the TTerms.properties file:

1.
2,
3.

Lo

g™
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Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)

From the File menu, select Open Base File.

Navigate to and select the TTerms.properties file. This file is in English. You
can also consult one of the other translations, such as the Russian translation
of the file (TTerms_ru.properties), when translating.

If you installed Tracker at the default installation location, the properties
files can be found at Program Files\ Tracker\ conf\com\ fgm\ tracker.

From the File menu, select New Target File,

Name the new target file appropriately, and save it in the same directory as

the base file.
You must name the file “TTerms_xx.properties,” replacing xx with the
appropriate two-character language code (for example,
TTerms_es.properties would be a Spanish translation). See the Appendix
for a list of valid language codes.

The new properties file must be saved in the same location as the base file
(for Tracker client installations that use the default installation location,
this is Program Files\ Tracker\ conf\ com\ fgm)\ tracker).

In the Target Value column, click in a field and type the translation of the
adjacent term listed in the Base Value column.

Repeat the above step for each row’s term.

When you have translated all terms, save the file by selecting Save from the
File menu,

To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)

o translate the TMessages.properties file:

Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
From the File menu, select Open Base File.
Navigate to and select the TMessages.properties file. This file is in English.
You can also consult one of the other translations, such as the Russian
translation of the file (TMessages_ru.properties), when translating.
If you installed Tracker at the default installation location, the properties
files can be found at Program Files\ Tracker\ conf\ com\ fgm\ tracker.
From the File menu, select New Target File.
Name the new target file appropriately, and save it in the same directory as
the base file.
You must name the file “TMessages_xx.properties,” replacing xx with the
appropriate two-character language code (for example,

21
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TMessages_es.properties would be a Spanish translation). See the
Appendix for a list of valid language codes.

The new properties file must be saved in the same location as the base file
(for Tracker client installations that use the default installation location,
this is Program Files\ Tracker\ conf\com\ fgm\ tracker).

In the Target Value column, click in a field and then type the translation of the
adjacent term listed in the Base Value column.

Repeat the above step for each row’s term.

When you have translated all terms, save the file by selecting Save from the
File menu.

To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)

P To translate the ISOCodeRes.properties file:

il
2
3.

% N

Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
From the File menu, select Open Base File.
Navigate to and select the ISOCodeRes.properties file. This file is in English.
You can also consult one of the other translations, such as the Russian
translation of the file (ISOCodeRes_ru.properties), when translating,
If you installed Tracker at the default installation location, the properties
files can be found at Program Files\ Tracker\conf\com\ fgm\ util.

From the File menu, select New Target File.

Name the new target file appropriately, and save it in the same directory as

the base file.
You must name the file “ISOCodeRes_xx.properties,” replacing xx with
the appropriate two-character language code (for example,
ISOCodeRes_es.properties would be a Spanish translation). See the
Appendix for a list of valid language codes.

The new properties file must be saved in the same location as the base file
(for Tracker client installations that use the default installation location,
this is Program Files\ Tracker\ conf\com\ fgm\ util).

In the Target Value column, click in a field and then type the translation of the
adjacent term listed in the Base Value column,

Repeat the above step for each row’s term.

When you have translated all terms, save the file by selecting Save from the
File menu,

To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)



ﬁ

9

Using Rosetta-J (Windows): Creating a New Translation

To translate the UIStrings.properties file:

¥y,

2,
3.

L
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Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
From the File menu, select Open Base File.
Navigate to and select the UlStrings.properties file, This file is in English. You
can also consult one of the other translations, such as the Russian translation
of the file (UIStrings_ru.properties), when translating.
If you installed Tracker at the default installation location, the properties
files can be found at Program Files\ Tracker\ conf\ com\ fgm\ util.

From the File menu, select New Target File.

Name the new target file appropriately, and save it in the same directory as

the base file.
You must name the file “UlStrings_xx.properties,” replacing xx with the
appropriate two-character language code (for example,
UIStrings_es.properties would be a Spanish translation). See the
Appendix for a list of valid language codes.

The new properties file must be saved in the same location as the base file
(for Tracker client installations that use the default installation location,
this is Program Files\ Tracker\ conf\ com\ fgm\ util).

In the Target Value column, click in a field and type the translation of the
adjacent term listed in the Base Value column.

Repeat the above step for each row’s term.

When you have translated all terms, save the file by selecting Save from the
File menu.

To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)

o translate the basic.properties file:

Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
From the File menu, select Open Base File.
Navigate to and select the basic.properties file. This file is in English. You can
also consult one of the other translations, such as the Russian translation of
the file (basic_ru.properties), when translating.
If you installed Tracker at the default installation location, the properties
files can be found at Program
Files\ Tracker\ conf\ javax\swing\ plaf\ basic\ resources.
From the File menu, select New Target File.
Name the new target file appropriately, and save it in the same directory as
the base file.
You must name the file “basic_xx.properties,” replacing xx with the
appropriate two-character language code (for example,
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basic_es.properties would be a Spanish translation). See the Appendix for
a list of valid language codes.

The new properties file must be saved in the same location as the base file
(for Tracker client installations that use the default installation location,
this is Program Files\ Tracker\ conf\ javax\ swing\ plaf\ basic\ resources).

In the Target Value column, click in a field and type the translation of the
adjacent term listed in the Base Value column.

Repeat the above step for each row’s term.

When you have translated all terms, save the file by selecting Save from the
File menu.

To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)

Need to add the translated files to other Tracker client computers?

Now that you have created the translation for the four properties

é files, you can copy these files to the other Tracker client
computers running Windows 2000 or Windows XP that will also
require the translated interface. You must save the files on each
Tracker client computer in the appropriate location (for example,
Program Files\Tracker\conf\com\fgm\tracker for TTerms and
TMessages; Program Files\Tracker\conf\com\fgm\util for
UlStrings and ISOCodeRes; or Program
Files\Tracker\conf\javax\swing\plaf\basic\resources for
basic.properties).
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Updating an Existing Translation

The following instructions are intended for users who already have a translated
properties file that they need to update. If you want to create a new version of a
properties file for a translation, see “Creating a New Translation” on page 19. The
instructions listed below are intended for users who need to change a translated
term or otherwise modify an already translated file,

P To update the translated TTerms_xx.properties file:

Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
From the File menu, select Open Base File.
Navigate to and select the appropriate base file.
From the File menu, select Open Target File.
Navigate to and select the appropriate translated TTerms_xx.properties file
(the “xx” will be replaced with the appropriate two-character language code,
such as “es”).
If you installed Tracker at the default installation location, this properties
file can be found at Program Files\ Tracker\ conf\ com\ fgm\ tracker.

6. Locate the term you need to update,

o Nl

é NOTE: You can easily determine which target terms need to be updated by
selecting a warning color for terms that exist in the base file only
(Edit>Preferences) and then enabling the warning colors display (“Enable color row
highlighting”). You can also sort the Target Values column by clicking the column
heading so that untranslated target values appear near the top of the window.

7. In the Target Value column, click in the cell and type the updated translation
of the adjacent term listed in the Base Value column.

8. Repeat the above step for each row’s term that you need to update.

9. When you have translated all terms, save the file by selecting Save from the
File menu,

10. To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)

p To update the translated TMessages_xx.properties file:

Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
From the File menu, select Open Base File,

Navigate to and select the appropriate base file.

From the File menu, select Open Target File.

Navigate to and select the appropriate translated TMessages_xx.properties
file (the “xx” will be replaced with the appropriate two-character language
code, such as “es”).

O SRR
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If you installed Tracker at the default installation location, this properties
file can be found at Program Files\ Tracker\ conf\ com\ fgm)\ tracker.

6. Locate the term you need to update.

é NOTE: You can easily determine which target terms need to be updated by
selecting a warning color for terms that exist in the base file only
(Edit>Preferences) and then enabling the warning colors display (“Enable color row
highlighting”). You can also sort the Target Values column by clicking the column
heading so untranslated target values appear near the top of the window.

7. Inthe Target Value column, click in the cell and type the updated translation
of the adjacent term listed in the Base Value column.

8. Repeat the above step for each row’s term that you need to update.

9. When you have translated all terms, save the file by selecting Save from the
File menu.

10. To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)

P To update the translation for the ISOCodeRes_xx.properties file:

1. Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)

2. From the File menu, select Open Base File.

3. Navigate to and select the appropriate base file.

4. From the File menu, select Open Target File.

5. Navigate to and select the appropriate translated ISOCodeRes_xx.properties
file (the “xx” will be replaced with the appropriate two-character language
code, such as “es”).

If you installed Tracker at the default installation location, this properties
file can be found at Program Files\ Tracker\ conf\ com\ fgm}\ util.

6. Locate the term you need to update.

é NOTE: You can easily determine which target terms need to be updated by
selecting a warning color for terms that exist in the base file only
(Edit>Preferences) and then enabling the warning colors display (“Enable color row
highlighting”). You can also sort the Target Values column by clicking the column
heading so untranslated target values appear near the top of the window.

7. Inthe Target Value column, click in the cell and type the updated translation
of the adjacent term listed in the Base Value column.

8. Repeat the above step for each row’s term that you need to update.

9. When you have translated all terms, save the file by selecting Save from the
File menu.
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10. To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)

p To update the translation for the UIStrings_xx.properties file:

1. Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)

2. From the File menu, select Open Base File,

3. Navigate to and select the appropriate base file.

4, From the File menu, select Open Target File.

5. Navigate to and select the appropriate translated UlStrings_xx.properties file
(the “xx” will be replaced with the appropriate two-character language code
such as “es”).

If you installed Tracker at the default installation location, this properties
file can be found at Program Files\ Tracker\ conf\ com\ fgm\ util.

6. Locate the term you need to update,

é NOTE: You can easily determine which target terms need to be updated by
selecting a warning color for terms that exist in the base file only
(Edit>Preferences) and then enabling the warning colors display (“Enable color row
highlighting”). You can also sort the Target Values column by clicking the column
heading so untranslated target values appear near the top of the window.

7. In the Target Value column, click in the cell and type the updated translation
of the adjacent term listed in the Base Value column.

8. Repeat the above step for each row’s term that you need to update.

9. When you have translated all terms, save the file by selecting Save from the
File menu,

10. To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)

To update the translation for the basic_xx.properties file:

Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
From the File menu, select Open Base File.
Navigate to and select the appropriate base file.
From the File menu, select Open Target File,
Navigate to and select the appropriate translated basic_xx.properties file (the
“xx” will be replaced with the appropriate two-character language code such
as “es”).
If you installed Tracker at the default installation location, this properties
file can be found at Program
Files\ Tracker\ conf\ javax\swing)\ plaf\ basic\ resources.

6. Locate the term you need to update.
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NOTE: You can easily determine which target terms need to be updated by
selecting a warning color for terms that exist in the base file only

& (Edit>Preferences) and then enabling the warning colors display (“Enable color row
highlighting”). You can also sort the Target Values column by clicking the column
heading so untranslated target values appear near the top of the window.

7. In the Target Value column, click in the cell and type the updated translation
of the adjacent term listed in the Base Value column,

8. Repeat the above step for each row’s term that you need to update.

9. When you have translated all terms, save the file by selecting Save from the
File menu.

10. To display the translated text you just created in the Tracker client, set the
Tracker client computer’s locale to match that of the properties file. (See
“Setting the Operating System Locale” on page 31.)
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Finding a Term in the Base or Target File

The Find feature of Rosetta-] can help you quickly locate a term whose translation
needs to be updated.

P To find terms in a base or target file:

1. Open the Rosetta-] application. (See “Opening Rosetta-]” on page 15.)
2. From the File menu select Open Base File.
3. Navigate to and select the appropriate base file.
To find a term in the base file, proceed to step 6.
To find a term in a target file, from the File menu select Open Target File.
Navigate to and select the appropriate target file.
From the Edit menu, select Find.
In the Find What field, type the text for which you want to search.
If you want to search for a case sensitive match with what you typed as search
criteria, click the Match Case check box.
Click the direction (Up or Down) radio button for the direction that you want
to search.
Selecting Up searches the open file from the cursor point to the top of the
window. Selecting Down searches the open file from the cursor insertion
point to the bottom of the window.

10. Click the Find Next button.

If there are matches to your search criteria, the row highlights. Click the
Find Next button to search for the next occurrence of the search criteria
(if any exist).

LN

X

@rnd
Find What: | | [ﬁ Find Next
- Direction ———— | W ‘

JUp @ Down

[C] Match Case

Figure 5. The Find dialog allows you to search the open target or
hase file.
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Replacing a Term in a Target File

The Find /Replace feature of Rosetta-] can help you quickly locate a term whose
translation needs to be replaced with text you type. Rosetta-] allows a user to
work with target terms only, not base terms. This restriction prevents users from
unintentionally modifying the base terms.

p To find and replace a term in a base or target file:

1. Open the Rosetta-] application. See “Opening Rosetta-]” on page 15.
2. From the File menu select Open Base File,
3. Navigate to and select the appropriate base file,
To find and replace a term in a base file, proceed to step 6.
4, To find and replace a term in a target file, from the File menu select Open
Target File,
Navigate to and select the appropriate target file.
From the Edit menu, select Replace,
In the Find What field, type the text that you want to replace.
In the Replace With field, type the text that will replace the text in the Find
What field.
If you want to search for a case sensitive match with what you typed as search
criteria, click the Match Case check box.
10. Click the direction (Up or Down) radio button for the direction that you want
to search.
Selecting Up searches the open file from the cursor point to the top of the
window. Selecting Down searches the open file from the cursor insertion
point to the bottom of the window.

11. Click the Find Next button to locate the Find What text.

If there are matches to your search criteria, the row highlights. Click the
Find Next button to search for the next occurrence of the search criteria
(if any exist).

12. If you want to replace the found term, click the Replace button. If you want to
replace ALL occurrences of the found text in the file, click the Replace All
button.

13. When all matches have been found or replaced, click the Cancel button to
close the Find Dialog box.
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Setting the Operating System Locale

Once you have translated the appropriate properties files and saved them in the
locations recognized by the Tracker client, you can easily display the translated
text in the Tracker client. Displaying a specific locale’s translation (provided it
exists as a correctly named properties file with the two-character language code)
is as simple as setting the Tracker client computer’s operating system regional
setting so that the selected locale matches that of the properties file you want to
use in the Tracker client.

é NOTE: During this operation, the operating system might prompt you for additional
software or drivers to support the target locale.

p To set the operating system locale in Windows 2000:

1. From the Tracker client computer’s desktop, click Start > Settings > Control
Panel.

Select Regional Options.

In the General tab, select the locale that matches the properties files you want
to display in the Tracker client.

To ensure the proper display of translated terms in the target locale, click the
Set Default button to enable the selected locale as the default for the
computer, If you do not select the locale as default, some characters might
display as question marks (?) in window titles.

Click the OK button.

To close the Regional Options window and save the setting, click the OK
button.
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P To set the operating system locale in Windows XP:

1. From the Tracker client computer’s desktop, click Start > Control Panel.

2. Double-click Regional and Language Options.

3. In the Regional Options tab, select the language that matches the properties
files you want to display in the Tracker client.

4, Click the Apply button to save the setting, or click the Cancel button to close
the Regional and Language Options window without making any changes.

5. Click the OK button to close the Regional and Language Options window.
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Troubleshooting Tips

The following tips, presented in the form of questions and answers, should help
you fix most common Rosetta-] issues or problems.

Why is the Tracker client not displaying the translated properties
file?

The most common reason why the Tracker client would not display the translated
text as expected relates to incorrect filenames or a file saved in the wrong location,
To troubleshoot this problem, try the following:

* Verify the location of the properties file on the Tracker client computer.
The TTerms and TMessages properties files should be located in
Tracker\ conf\com)\ fgm\ tracker (if you installed the Tracker client in the
default installation location under Program Files); the UlStrings and ISO-
CodeRes properties files should be located in Tracker\ conf\com) fgm) util
(if you installed the Tracker client in the default installation location under
Program Files); the basic.properties file should be located in Program
Files\ Tracker\ conf\ javax\swing\ plaf\ basic\ resources for default loca-
tion installations of Tracker.

Rosetta-] also features a set of properties files in
Rosetta)\ conf\ com\ fgm\ rosetta and Rosetta\ conf\ com\ fgm\ util, but
these are NOT the files accessed by the client.

* Verify the filename. It must be in the format TMessages_xx.properties,
TTerms_xx.properties, UIStrings_xx.properties, basic_xx.properties, or
ISOCodeRes_xx.properties, where the “xx” is replaced with the appropri-
ate two-character language code.

* Verify the locale selected for the client computer matches the properties
file. For example, a TTerms_fr.properties would require the locale at the
operating system level to be set to France.

Why are some of the Tracker clients displaying translated text
while others are not?

Each Tracker client computer requires the translated properties files to be
installed. Once you create one set of translated properties files, you can then copy
the files to the appropriate location on the other Tracker client computers running
Windows 2000.

How do | fix an incorrectly-translated term?

You can easily open an existing target file that contains the translation and then
correct the error in the target column. For details, see “Updating an Existing
Translation” on page 25.
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Why don’t the characters | am typing appear in the appropriate
language?

In Windows 2000 and Windows XP, there are regional settings for the display and
for the keyboard-based input. The instructions in this guide describe how to set
the display locale so that the Tracker client can correctly display the translated
interface. However, to change the input locale which affects the appearance of the
characters as you type, in Windows 2000 you must click the Input Locales tab in
the Regional Options window and then add the appropriate input locales; in
Windows XP you must click the Details button in the Lanuage tab of the
Regional and Lanuage Options window.
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Exiting Rosetta-J

The following instructions describe how to exit Rosetta. If you have any unsaved
Rosetta-] data, such as changes made to a target file, you will be prompted to save
your changes before Rosetta-] closes. Exiting Rosetta-] closes all open Rosetta-]
files.

p To exit Rosetta-]:

¢ From the File menu, select Exit.

Rosetta-] prompts you to either save any files that have been edited since
the last save or confirm that you wish to exit the system, and closes.
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Uninstalling Rosetta-J

The following instructions describe how to uninstall Rosetta-].,

P To uninstall Rosetta-] from a computer running Windows 2000 or Windows XP:

1.
2,

Mok

If the Rosetta-] application is open, close it.
From the client computer’s Start menu, select either Settings > Control Panel
(Windows 2000) or Control Panel (Windows XP).
From the Control Panel window, double-click either Add/Remove Programs
(Windows 2000) or Add or Remove Programs (Windows XP).
Select the Rosetta entry.
Click the Change/Remove button.
In the Uninstall Rosetta window, click the Uninstall button.
When the uninstallation completes, click the Done button,
To close the window, click the Close button.
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