Release Notes

IMSMA V5.06
This document contains information highlighting new functionality, improvements and major fixes implemented since IMSMA V5.05.04 Patch Release. This document is intended as a quick reference to the major changes and overall functionality of the IMSMA V5.06 Release.  
Installation and Upgrades

New and Improved Functionality
· Upgrade window message – V5.06 does not include “Not Specified” and “Other” point types as options when entering geographical information into the system. (see “Point Type list” in the Field Reports Data Entry and Approval section for more information). 
· If a user upgrades a pre-5.06 database that contains points with a point type of “Not Specified” or “Other,” the Upgrade window displays a message that the points changed from “Not Specified” or “Other” to “Unknown.”
· If a user upgrades a pre-5.06 database that does not contain any point with a point type of “Not Specified” or “Other,” the Upgrade window does not display any message about point types.
· Radio button/combo box options – Single-select CDFs with radio buttons that were created prior to V5.05 can now be changed to single-select CDFs with combo boxes when the database is upgraded to V5.06. The radio button/combo box options are available in both the Data Inventory Manager and the Field Report Template Designer.
· Field Report Dates – This is a fix.  Data Entry Date (known as “Last Updated Date” in the application) and Report Received Date data were swapped.  Upgrade makes sure that these fields have the correct data.
Main Navigation

New and Improved Functionality

· New Help Menu

· User Guides – The submenu is built dynamically. All folders and PDFs stored in the IMSMA_HOME/IMSMA Documentation/User Guides folder are detected and populate the User Guides submenu.

· IMSMA FAQ – Launches a PDF viewer and displays the IMSMA FAQ.pdf file stored in the IMSMA_HOME/IMSMA Documentation folder.  

· Support – Launches the Support window with support information that is defined in the IMSMA_HOME\client\conf\Client.properties file.  Below is a list of 4 variables used for the Support window and they can be edited as needed: 

· telephoneNumber=

· openingHours=

· emailAddress=

· urlAddress=

· About IMSMA – Launches the About IMSMA window.  Below is a list of 2 variables used for the About IMSMA window and they can be edited as needed:
· donorInformationLine1=

· donorInformationLine2=

· About IMSMA submenu – The About IMSMA submenu under the File menu has been moved to the Help menu.
Field Report Template Designer and Data Inventory Manager
New and Improved Functionality

· Setting required fields – This is an enhancement that allows users to set fields (or data elements) on a field report template as required fields. There are 2 options on the Component Editor Window to support this feature:
· Required checkbox – Check this option to set the field as a required field. Note that date fields and subobjects such as “Device” cannot be set as required fields.
· Display Required Colour checkbox – Check to display the border of the required field in Blue colour.
Added business logic also prevents users from approving field reports that have empty required fields. A Warning message displays showing a list of all empty required fields.
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· Setting default values – This is an enhancement that allows users to set default value(s) for single-select data fields (radio buttons or combo boxes) and multiple-select data field (checkboxes). This includes single- and multiple-select CDFs as well. A Default Value checkbox is available on the Component Editor Window to allow users to set a Radio Button Option as default.  The Combo Box Options window available from the Component Editor Window allows the user to select the default by selecting the option in the table.
· Creating CDFs with the same name – This is a fix. Previously, CDFs with the same name but different data types were visible only in the Field Report Template Designer and not the Data Inventory Manager or View Designer. With the fix, multiple CDFs with the same name but different data types can be created and accessed in both the Field Report Template Designer and the Data Inventory Manager.
· Using the Impact Survey – Priority options list – This is a fix. Previously, the Impact Survey – Priority options list displayed different values in the Data Inventory Manager compared to those in the Field Report Template Designer. Now, the options lists match.
Field Report Data Entry
New and Improved Functionality

· Tabbing between data elements – When entering data into a field report template, users can tab among the various data elements in the template. V5.06 includes the following options for setting the tab order if the field report template is designed as recommended (see “Recommendation” below):
· Users can tab sequentially through options lists. This includes lists with radio buttons and lists with checkboxes.
· Users cannot use tabs within text fields. Tabbing within a text field moves the cursor to the next data element.
· Users can tab from data element to data element sequentially, from top-to-bottom and left-to-right. The page scrolls with successive tabs.
Recommendation: Tab order is determined by the position of a data element or value on the page. When a user presses the Tab key, the next data element or value to be selected is the next highest and left-most one. This means that the data elements and values must be precisely aligned horizontally and vertically. Using the “Align” function in the Field Report Template Designer will help ensure that the elements and values are properly aligned and that users can follow the desired tab order in the templates. 
· Unselecting radio button options – In previous versions of IMSMA, users could only deselect an option from a radio button list by selecting another option. They could not revert back to having all options blank (or unselected) when a selection had already been made. V5.06 lets users deselect an option by selecting it again (usually by clicking). They then can save or submit a field report without making any selection for an options list.  Note: If there is a default radio button option, then this selection will be made each time the report is opened if no other radio button is selected.
· Entering geospatial data
· Point No and Local ID and Shape ID fields - The Point No and Local ID fields on the Point window for both points and polygons/polylines and the Shape ID field on the polygon window are autopopulated with a consecutive number for each new entry. Note, though, that these fields can still be manually edited. For points, the sequence begins as follows:
· Point No = 1
· Local ID = Point – 1
For polygons/polylines, the sequence begins as follows:

· Shape ID = 1
· Point No = 1
· Local ID = Polygon or Polyline 1 – 1
· Point Type list 
· The options listed in the table below were either added or deleted from the Point Type list. Existing points whose point type was deleted are recategorised as “Unknown” point type (see “Upgrade window message” in the Installation and Upgrades section for more information.
	Added options
	Deleted options

	Evidence Point
	Not Specified

	Usage Point
	Other


· The Point Type list on the Point window for polygons/polylines defaults to “Start Point” for the first new point of a set entered. The list defaults to “Turning Point” for subsequent points of a set entered.
· #6072 - Entering negative coordinates
· Points entered in dd:mm or dd:mm:ss where the degree is 0 will no longer incorrectly convert this to -0 
· Previewing geospatial data – This is a fix. When reconciling by combining items, only the points and polygons/polylines for the item in the field report displayed on the map when previewing the geospatial data on the Replace/Combine window. Now, the points and polygons/polylines for the item in the field report and the item it is being combined with (the item already approved in the system) display on the map.
· Viewing and printing field report attachments – Users can now view and print field report attachments via the Attachments: <Field Report Template> window as shown in the figure below. Note that the field report must first be saved to view and print its attachments. 
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· Printing field reports – In previous versions of IMSMA, lengthy table data in field reports would not print properly. V5.06 fixes this in two ways:
· Points, polygons/polylines and device tables are printed at the end or in the annex of the printout.
· The content of each of the table cell wraps to the next line so all content is visible in the table.
· Field Report Dates

· Report Received Date is now set on the initial save, Data Entry Date (Last Updated) is updated on every edit.
Current View

New and Improved Functionality

· Displaying CDF number fields in current views – This is a fix. When a CDF number field was added to a current view, it would cause the current view to “break” and become unusable. Now, CDF number fields can be used in current views.
· Printing current views with many geospatial points – This is a fix. Previously, current views that listed numerous points in the Geospatial tables did not print. Now, the current views print properly without regard to the number of points listed in a geospatial table.
Search
New and Improved Functionality

· Creating searches – This is a fix. When creating a new search, the selected search criterion in a list would default back to the first criterion in the list when the search was saved or included a prompt for certain search items. (For example, a hazard search on locations by country structure would default back to locations by calculated area, the first criterion in the list.) This has been fixed.
· Filtering item lists and auxiliary data lists – Item lists and auxiliary data lists have new default settings as outlined below. 
· Pre-filter – certain lists open without displaying data so that the user can apply a filter before retrieving the data
· All Quick Search lists windows
· Reconciliation and Link choosers
· Task - Objective and Related Item choosers
· Work Item - Associated MA Activity choosers
· Item list defaults – pertains to lists accessed from the Search menu such as Search > Hazard 
· Windows open to an empty list.
· “Local ID” is the first or leftmost column in the list.
· The filter attribute is set to “Local ID.”
· The filter operator is set to “Contains.”
· Auxiliary data list defaults – pertains to Data Entry > Organisations or Data Entry > Places, lists which can also be accessed via widgets on field report templates
· “Local ID” is the first or leftmost column in the list.
· The filter attribute is set to “Local ID.”  
· The filter operator is set to “Contains.”
Importing

New and Improved Functionality

· Importing attachments from IMSMA Mobile – This is a fix. Attachments included in field reports created on IMSMA Mobile were not importing correctly. Although imports appeared to complete successfully, attachments created a 0 byte file and could not be opened. Attachments from IMSMA Mobile field reports import correctly now.
· Importing field reports – V5.06 includes changes to the field report import process to make it consistent between the File menu and Workbench options and to reduce the number of buttons on the Workbench window. Previously, MaXML and MDML imports could be done from the Workbench while only MaXML imports could be done from the file menu. Now, both options are available from either path.
· Consistent process - Whether selecting File > Import > Field Reports or clicking the Import button ([image: image3.bmp]) on the Workbench window, the new Import Options window displays where users can choose to import MaXML or MDML files.
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Then the process continues as it did in V5.05 for importing MDML files via the Workbench or MaXML files via the File menu. Note that the Import Options window closes after clicking “OK.”
· Reduced number of buttons – Previously, the Workbench had 4 icons for field report import and export: import MaXML, import MDML, export MaxML and export MDML. Now, there are only 2 icons: an Import icon and an Export icon. The Import icon allows users to import field reports in either MaXML or MDML format. The Export icon allows users to export field reports as MaXML, MDML or TXT.
· Importing bearing and distance values – V5.06 includes two enhancements to the field report import process so that IMSMA Remote Entry users can enter geospatial data in bearing and distance (instead of latitude and longitude) and import those values into IMSMA. Both when importing bearing and distance values using the geospatial widget and when importing field reports into the system, IMSMA calculates the latitude and longitude from the bearing and distance values entered and stores the values in the system.
· Importing XLS files – V5.06 includes two fixes to the process for importing XLS files. They are:
· Fix for validation error – Validation errors (for example, dates in the incorrect format) that occurred while importing XLS files would cause the client to close. V5.06 handles the errors without closing the client.
· Fix for ordering file error – After running an XLS import, subsequent imports did not use the selected import ordering file, but instead used the import ordering file from the first import attempt. Now, the selected import ordering file is used for each new import.
List of all Defects and Change Requests Addressed in the IMSMA V5.06.00 Release
	ID
	Description
	Priority
	Type
	Test Results

	6172
	Add message to Upgrade window if point types were changed during Dec 2010 upgrade
	 
	Change Request
	 

	6167
	Single Select CDFs are not upgraded to allow combo boxes
	 
	Defect
	 

	6171
	Impact Survey Priority shows different enum values in form designer and DIM
	 
	Defect
	PASSED

	6175
	Field Report dates are not set correctly
	 
	Defect
	 

	6176
	Location labelling shows up 6 times
	 
	Defect
	PASSED

	6178
	If two CDFs have the same name, only one shows up in the View Designer.
	 
	Defect
	PASSED

	6120
	Fail to migration - java.lang.NoClassDefFoundError: com/fgm/util/SecurityUtils
	Show-Stopper
	Defect
	 

	4819
	Required localID AND point number for coordinate entry is burdensome.
	Priority 1
	Change Request
	PASSED

	5911
	Make Field Required on Field Report Editor
	Priority 1
	Change Request
	PASSED

	6004
	Remove Non specified and Other options from the Point Type enum
	Priority 1
	Change Request
	 

	6005
	Add 5 new options for Point Type enum
	Priority 1
	Change Request
	PASSED

	6050
	Add the ability to View and Print Attachments
	Priority 1
	Change Request
	PASSED

	6070
	Be able to handle Bearing/Distance data on Field Report Import
	Priority 1
	Change Request
	 

	6073
	Object List - Add the ability to pre-filter the lists
	Priority 1
	Change Request
	PASSED

	6074
	Object List - Performance hit when a List contains CDF and/or Country Structure
	Priority 1
	Change Request
	 

	6075
	Form - Tab order
	Priority 1
	Change Request
	PASSED

	6076
	Form - Add the ability to unselect a single select item (radiobutton) during data entry
	Priority 1
	Change Request
	 

	6077
	Geospatial Widget - set default value to point type, point local id, and point number
	Priority 1
	Change Request
	PASSED

	6078
	Geospatial Widget Import - Support Bearing and Distance
	Priority 1
	Change Request
	 

	6081
	GIS Preview - Show Field Report data only
	Priority 1
	Change Request
	PASSED

	6212
	Cosmetic change request for IMSMA V5.06
	Priority 1
	Change Request
	 

	5901
	Attachments from IMSMA Mobile do not import correctly
	Priority 1
	Defect
	PASSED

	5933
	XLS Import validation error caused client to close
	Priority 1
	Defect
	 

	5936
	XLS Import remembers first Import Ordering File
	Priority 1
	Defect
	 

	5985
	Cannot reload saved search with linked CDF data
	Priority 1
	Defect
	PASSED

	5986
	Error displaying CDF number fields in Current View
	Priority 1
	Defect
	 

	5996
	GIS Preview displays Reconcile as Combine incorrectly
	Priority 1
	Defect
	PASSED

	5997
	Saved Search -- Country Structure criteria gets reset to "calculated area"
	Priority 1
	Defect
	PASSED

	6071
	Data inconsistency issue in Afghan
	Priority 1
	Defect
	PASSED

	6072
	Issue when entering negative coordinates in dd:mm:ss or dd:mm format
	Priority 1
	Defect
	 

	6082
	Field report printing - Issue printing data in tables (point/poly tables, device table)
	Priority 1
	Defect
	PASSED

	6083
	Field Report printing
	Priority 1
	Defect
	 

	6165
	Unable to set CDF Single Select as Combo Box
	Priority 1
	Defect
	 

	6168
	Error printing CV with lots of points
	Priority 1
	Defect
	PASSED

	6170
	DIM - Only displays 1 CDF out of multiple CDFs created with the same name but different data type
	Priority 1
	Defect
	PASSED

	6185
	Current View data cut off (by margins?) when printing
	Priority 1
	Defect
	 

	6213
	Missing "Uncategorised" category for Task and Work Item
	Priority 1
	Defect
	 

	6218
	Unable to import mdml with attachment data
	Priority 1
	Defect
	 

	5903
	Field Report Date Entry Enhancements
	Priority 2
	Change Request
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